【凤凰社】初学Spring踩的史前巨坑

  最近Beacuse学习需要,本人学完JavaWeb就立马跟战Spring,中间跳了太多步骤,导致在学习Spring过程中遇到了各种困难,看视频也是无济于事,就只可以将手中的代码改为面向百度编程。

  话不多说,直接上坑。

  1.开发工具的坑

    目前了解的仅有Eclipse和MyEclipse两个开发工具,先说MyEclipse,这个开发工具确实比Eclipse更适合使用Spring进行开发,But用久了Eclipse(我以前就用这个)就很难搞定这个软件,我从网上下载安装了Spring的插件(https://blog.csdn.net/qq_36127212/article/details/78158523)然后又在自己的项目中导入了Spring的jar,我在MyEclipse中用的是JDK1.8,So我下了个Spring5.2.x的......我并不知实情,So很自然的我第一个Hello Spring程序没可以在MyEclipse中实现,然而真正让我放弃这个软件的是我不知道怎么在项目中新建Java的class文件!!!我百度翻了一晚上都没这个相关的问题,可可以是我真的笨到前无古人后无来者......

    MyEclipse实在行不通,我就老老实实转Eclipse了,But解决了建class文件的问题后我发现了新的问题。

  2.Spring框架配置

      (1).Spring的插件版本

          在Eclipse上使用Spring插件是需要和自己正在使用的Eclipse匹配起来的,不然就会出各种错误,然后我翻遍了百度说是从这个软件里面下载,But我搜出来的结果不一样,So没成功。我又看了很多教程,终于知道了怎么去下和自己版本对应的Spring插件,虽然官网都有But说的模模糊糊,最后也是在大佬的帖子下找到了(https://blog.csdn.net/cuker919/article/details/81482099

      (2).Spring的jar配置版本

           这真的是我自学以来踩过最大的坑,我发誓以后一定要脚踏实地的学习,不然真的懵到自己姓什么都不知道。我当时的那个JavaWeb项目的JDK是1.7的,然后我不知道我用了Spring的5.2.x的配置,写完程序运行不出意外全是报错,大概就是我的JDK不支持5.2.x的Spring框架,于是我就按照错误信息去找了解决办法,跟我一样的情况少的可怜,But也功夫不负有心人,我找到了,1.7是用的Spring4.3.x于是我又去翻资源,在这个帖子下找到了4.3.x的下载地址(https://blog.csdn.net/qq_39293475/article/details/82712791)。然后替换完了我又运行,又出错了。

            按照错误信息,我是缺少了一个叫Apache Commons的jar,于是我又Start面向百度编程(https://www.cnblogs.com/2296bbs/p/5571276.html),终于也是找到了,下载地址(http://commons.apache.org/proper/commons-logging/download_logging.cgi)。解决这个问题我又Start运行。好,又出错了....

            这次的错误是说我的XML文件找不到,于是Start面向百度编程....终于找到了答案(https://blog.csdn.net/hubin1989/article/details/51407618)。

            最终,我终于在控制台看到了这样一句话:Hello Spring.....心情复杂,但好在我看见了门槛,就这样吧,写这些最重要的是想让自己记住这些坑,以防以后再踩。

 


0 评论

回复